npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! grpc@1.10.1 install: `node-pre-gyp install --fall

错误信息:

D:\project\eyeshot\eyeshot\Source>npm install
npm WARN deprecated boom@4.3.1: This version is no longer maintained. Please upgrade to the latest version.

> grpc@1.10.1 install D:\project\eyeshot\eyeshot\Source\node_modules\grpc
> node-pre-gyp install --fallback-to-build --library=static_library

node-pre-gyp ERR! Pre-built binaries not installable for grpc@1.10.1 and node@8.11.3 (node-v57 ABI, unknown) (falling back to source compile with node-gyp)
node-pre-gyp ERR! Hit error connect ETIMEDOUT 172.217.161.176:443
gyp ERR! configure error
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable.
gyp ERR! stack     at PythonFinder.failNoPython (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:483:19)
gyp ERR! stack     at PythonFinder.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:508:16)
gyp ERR! stack     at C:\Program Files\nodejs\node_modules\npm\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:152:21)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "configure" "--fallback-to-build" "--library=static_library" "--module=D:\\project\\eyeshot\\eyeshot\\Source\\node_modules\\grpc\\src\\node\\extension_binary\\node-v57-win32-x64-unknown\\grpc_node.node" "--module_name=grpc_node" "--module_path=D:\\project\\eyeshot\\eyeshot\\Source\\node_modules\\grpc\\src\\node\\extension_binary\\node-v57-win32-x64-unknown"
gyp ERR! cwd D:\project\eyeshot\eyeshot\Source\node_modules\grpc
gyp ERR! node -v v8.11.3
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute 'C:\Program Files\nodejs\node.exe C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js configure --fallback-to-build --library=static_library --module=D:\project\eyeshot\eyeshot\Source\node_modules\grpc\src\node\extension_binary\node-v57-win32-x64-unknown\grpc_node.node --module_name=grpc_node --module_path=D:\project\eyeshot\eyeshot\Source\node_modules\grpc\src\node\extension_binary\node-v57-win32-x64-unknown' (1)
node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (D:\project\eyeshot\eyeshot\Source\node_modules\grpc\node_modules\node-pre-gyp\lib\util\compile.js:83:29)
node-pre-gyp ERR! stack     at emitTwo (events.js:126:13)
node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:214:7)
node-pre-gyp ERR! stack     at maybeClose (internal/child_process.js:925:16)
node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)
node-pre-gyp ERR! System Windows_NT 10.0.17134
node-pre-gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "D:\\project\\eyeshot\\eyeshot\\Source\\node_modules\\grpc\\node_modules\\node-pre-gyp\\bin\\node-pre-gyp" "install" "--fallback-to-build" "--library=static_library"
node-pre-gyp ERR! cwd D:\project\eyeshot\eyeshot\Source\node_modules\grpc
node-pre-gyp ERR! node -v v8.11.3
node-pre-gyp ERR! node-pre-gyp -v v0.7.0
node-pre-gyp ERR! not ok
Failed to execute 'C:\Program Files\nodejs\node.exe C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js configure --fallback-to-build --library=static_library --module=D:\project\eyeshot\eyeshot\Source\node_modules\grpc\src\node\extension_binary\node-v57-win32-x64-unknown\grpc_node.node --module_name=grpc_node --module_path=D:\project\eyeshot\eyeshot\Source\node_modules\grpc\src\node\extension_binary\node-v57-win32-x64-unknown' (1)
npm WARN @agm/core@1.0.0-beta.5 requires a peer of @angular/common@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @agm/core@1.0.0-beta.5 requires a peer of @angular/core@^5.0.0 || ^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/fire@5.1.0 requires a peer of @angular/common@>=6.0.0 <8 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/fire@5.1.0 requires a peer of @angular/core@>=6.0.0 <8 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/fire@5.1.0 requires a peer of @angular/platform-browser@>=6.0.0 <8 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/fire@5.1.0 requires a peer of @angular/platform-browser-dynamic@>=6.0.0 <8 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/fire@5.1.0 requires a peer of firebase@^5.5.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/fire@5.1.0 requires a peer of rxjs@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @angular/platform-server@4.4.3 requires a peer of @angular/animations@4.4.3 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/splash-screen@4.0.1 requires a peer of @ionic-native/core@^3.6.0 || >=4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @ionic-native/status-bar@4.0.1 requires a peer of @ionic-native/core@^3.6.0 || >=4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN angular2-google-maps@0.17.0 requires a peer of @angular/common@^2.3.1 but none is installed. You must install peer dependencies yourself.
npm WARN angular2-google-maps@0.17.0 requires a peer of @angular/core@^2.3.1 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-angular@3.8.0 requires a peer of @angular/common@4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-angular@3.8.0 requires a peer of @angular/compiler@4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-angular@3.8.0 requires a peer of @angular/compiler-cli@4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-angular@3.8.0 requires a peer of @angular/core@4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-angular@3.8.0 requires a peer of @angular/forms@4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-angular@3.8.0 requires a peer of @angular/http@4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-angular@3.8.0 requires a peer of @angular/platform-browser@4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-angular@3.8.0 requires a peer of @angular/platform-browser-dynamic@4.4.4 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-angular@3.8.0 requires a peer of rxjs@5.4.3 but none is installed. You must install peer dependencies yourself.
npm WARN ionic-angular@3.8.0 requires a peer of zone.js@0.8.18 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! grpc@1.10.1 install: `node-pre-gyp install --fallback-to-build --library=static_library`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the grpc@1.10.1 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\lenovo\AppData\Roaming\npm-cache\_logs\2018-11-05T01_38_18_123Z-debug.log

解决办法:

执行以下命令:npm install --save @google-cloud/vision

npm install grpc

npm install -g node-gyp

 

 

node-pre-gyp ERR! Tried to download(403): https://node-zopfli.s3.amazonaws.com/Release/zopfli-v2.0.2-node-v57-win32-x64.tar.gz node-pre-gyp ERR! Pre-built binaries not found for node-zopfli@2.0.2 and node@8.12.0 (node-v57 ABI, unknown) (falling back to source compile with node-gyp) gyp ERR! configure error gyp ERR! stack Error: Can't find Python executable "python2.7", you can set the PYTHON env variable. gyp ERR! stack at PythonFinder.failNoPython (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:484:19) gyp ERR! stack at PythonFinder.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:509:16) gyp ERR! stack at C:\Program Files\nodejs\node_modules\npm\node_modules\graceful-fs\polyfills.js:284:29 gyp ERR! stack at FSReqWrap.oncomplete (fs.js:152:21) gyp ERR! System Windows_NT 10.0.17134 gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "configure" "--fallback-to-build" "--module=C:\\Users\\78472\\Desktop\\vue-multi-page\\node_modules\\node-zopfli\\lib\\binding\\node-v57-win32-x64\\zopfli.node" "--module_name=zopfli" "--module_path=C:\\Users\\78472\\Desktop\\vue-multi-page\\node_modules\\node-zopfli\\lib\\binding\\node-v57-win32-x64" "--python=python2.7" "--msvs_version=2015" gyp ERR! cwd C:\Users\78472\Desktop\vue-multi-page\node_modules\node-zopfli gyp ERR! node -v v8.12.0 gyp ERR! node-gyp -v v3.8.0 gyp ERR! not ok node-pre-gyp ERR! build error node-pre-gyp ERR! stack Error: Failed to execute 'C:\Program Files\nodejs\node.exe C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js configure --fallback-to-build --module=C:\Users\78472\Desktop\vue-multi-page\node_modules\node-zopfli\lib\binding\node-v57-win32-x64\zopfli.node --module_name=zopfli --module_path=C:\Users\78472\Desktop\vue-multi-page\node_modules\node-zopfli\lib\binding\node-v57-win32-x64 --python=python2.7 --msvs_version=2015' (1) node-pre-gyp ERR! stack at ChildProcess.<anonymous> (C:\Users\78472\Desktop\vue-multi-page\node_modules\node-pre-gyp\lib\util\compile.js:83:29) node-pre-gyp ERR! stack at emitTwo (events.js:126:13) node-pre-gyp ERR! stack at ChildProcess.emit (events.js:214:7) node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:915:16) node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5) node-pre-gyp ERR! System Windows_NT 10.0.17134 node-pre-gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\78472\\Desktop\\vue-multi-page\\node_modules\\node-pre-gyp\\bin\\node-pre-gyp" "install" "--fallback-to-build" node-pre-gyp ERR! cwd C:\Users\78472\Desktop\vue-multi-page\node_modules\node-zopfli node-pre-gyp ERR! node -v v8.12.0 node-pre-gyp ERR! node-pre-gyp -v v0.6.39 node-pre-gyp ERR! not ok 以上是错误内容
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页